Webfrontend #580

Bug: Additional GET request after POST in Firefox

Added by Alexander Blum over 3 years ago. Updated about 2 years ago.

Status:ErledigtStart date:
Priority:NormalDue date:
Assignee:Alexander Blum% Done:

100%

Category:-
Target version:Repertoire 1) Testing phase I

Description

Strange behaviour of firefox: If there's an emtpy href tag somewhere (?) within the tags, a POST request causes firefox to fire an additional GET request with no parameters to the same URL for whatever reasons. This conflicts with form persistance, as form controllers are deleted per default, if the form id is not send as GET/POST parameter. As this is quite hard to debug, this ticket should be a documentation of this bug.


Related issues

Related to collecting_society - Webfrontend #592: Bug in registry cache? Erledigt

Associated revisions

Revision 65580d4c
Added by Alexander Blum over 3 years ago

fixes #580: firefox bug with empty href attributes

Revision 215e6338
Added by Alexander Blum over 3 years ago

fixes #580: firefox bug with empty href attributes

History

#1 Updated by Alexander Blum over 3 years ago

Btw: the emtpy href was the favicon, which was only added to the registry in the frontend resource, but not the backend resource.

#2 Updated by Alexander Blum over 3 years ago

  • Status changed from Neu to Erledigt
  • % Done changed from 0 to 100

Applied in changeset commit:collecting_society_portal_repertoire|215e6338ddec00e2a0df9913495426d038ea0c09.

#3 Updated by Alexander Blum over 3 years ago

#4 Updated by Alexander Blum about 2 years ago

  • Target version changed from 1) Testing phase I to Repertoire 1) Testing phase I

#5 Updated by Alexander Blum about 2 years ago

  • Project changed from repertoire to collecting_society

Also available in: Atom PDF